01 Impala drivetrain noise

I have a 01 Impala LS that just started making a rhythmic whirring noise near the front right wheel that changes speed with the tire rotation speed...at a
glance, it sounds like a brake problem. But, I replaced the pads and checked out the brakes it all seems fine. The noise does change when I swerve the car left and right...seems to get louder when I go right. OK...so maybe it's a wheel bearing you would think...but there doesn't seem to be any play in the bearing when I put the car up. Using a mechanics stethoscope right on the transaxle case, a friend and I think we have pinpointed the sound to coming from the output area transaxle itself.
Anyone else had any trouble or experience like this that they can share?
I'm probably giong to take it into a shop and let them figure out what it is, but thought I would ask anyways.
thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
chumpus wrote:

under warranty nd it was and split gear.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
chumpus wrote:

Sounds like it's the left front wheel bearing. They don't have to be loose to be noisy. We replace wheel bearing assemblies all the time that are noisy, but not loose.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You have a bad wheel bearing. I thought the same thing with my 01 Impala, changed both my driveaxles to no avail - changing RF wheel bearing fixed the noise.
On Fri, 21 Oct 2005 20:32:36 -0500, snipped-for-privacy@gmail-dot-com.no-spam.invalid (chumpus) wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.