02’ Sunfire mileage issues

Hey there, recently my sunfire has been sucking back gas like nothing else. It all happened after a big storm a few weeks ago. I was getting 600km for a full tank and am now getting between 200-300km. There are
no leaks and it seems to run fine. I took it in to a shop and they suggested having the intake cleaned as it probably has a lot of carbon build-up.
I’m a little tight on cash right now so I was wondering if anybody had any other ideas as to what it could be. I have talked to people around work and friends, all say that it’s a possibility, but there are many other things that could be wrong as well.
Was just hoping for some ideas.
Thanks. =)
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

When was the last tune up (spark plugs and wires, fuel filter, air filter) done?
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would double check for leaks or double check the mileage, thats a huge difference especially if the car doesn't run any different. Check while the car is running, lines, fuel rail & injectors.

Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.