1982 C10 4.1l straight 6 backfiring through exhaust

I just bought a 1982 C10 with a 4.1l straight 6.. Seems to be backfiring through the exhaust....Mostly when at high speeds and when letting off the gas.....And in park when i give it some gas and
let off.....Any ideas where to start?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Could be ignition timing, vacuum leak, stuck heat riser, or carb set * way * to lean. Could also be ignition problem such as failing condenser, or stuck weights.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The_Gear snipped-for-privacy@webtv.net (Steve Cook) wrote in message

Most likely you have an exhaust leak somewhere such as head/manifold or manifold/exhaust pipe flange, also I think this P/U has some major exhaust air injection plumbing on the manifold with the reed type valve units on the secondary air pipes. If so plug or crimp these hoses temp. to see if this stops the backfiring.
In short if the thing runs good but backfires the exhaust system is sucking air in somewhere. If it backfires and runs bad then look at ignition first then mixture then "other"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.