1988 buick park avenue 3.8 ltr

my 88 park avenue stopped running and acts like it might start but doesnt. any ideas?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check for spark, spray carb cleaner into the intake see if it starts, basic checks.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Low fuel pressure ? Commonly caused by failing fuel pump... Water in gas? Plugged fuel filter? Ignition system failure? Timing chain jumped?
Lots of possiblities, so you need to eliminate them, one at the time. Dont just start replacing crap, willynilly.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i checked the fuel pump ignition has spark and i was told that this motor doesnt have a timing chain but gears instead..not sure if this is correct
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How much fuel pressure did you register?
I show it as having a timing chain, and an internal balance shaft geared to the camshaft. Maybe I am off by a couple of years.
If your spark does not come exactly when the cylinder has fuel charge and compression, it will run roughy or not at all.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
old car.whats the motor.what's the mileage.if the fuel pump has never been replaced it seems a prime suspect.squirt gas directly in air intake and see if it runs.if no i would suspect ignition modual or coil.if 3800 could also be timming chain.(high mileage)any recent work to motor or car..more details mean a better diagnosis.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i tried spraying carb cleaner into intake...didnt help..it does have 130,000 miles on engine..no recent work done on it and someone said check the ..ill call it harmonic balancer cause they have a rubber insert and have a sensor that ...well i forgot but i did check the rubber insert thing and seems ok..im still lost
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you really do have spark, then do a compression test.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There is sensor in the timing chain cover, which is actuated by a magnet attached to the gear. It is not uncommon for that magnet to fall off, and a code will be set. It does not stop the engine from running, in my experience.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.