1990 Chevrolet Lumia Will Not Start

My Chevrolet Lumina, 4 cyl, will not start. It cut off when I was driving it. There was no default code present. The valves started to keep a lot of noise before it cut off. I have replaced the ignition coils, crank
shaft sensor, and ignition module. The fuel pump is working.
"HELP"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you have spark, will it start if you spray carb cleaner into the intake, whay did you replace all those parts, if try ing to save money it now cost you and it is not fixed, a competent mechanic could probably diagnose this in minutes.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

also im not familar with this engine out of memory. does it have a timing belt? how long had the valves been making noise? minutes? seconds? months? you dont specify. if minutes could valve timing have jumped or something of that nature. if so that would explain the no start and shut off. say it jumped enough to make it rattle (spark knock or something) then another jump to far enough out that it wont run at all.... i dont know this forsure as i have not looked at your engine in person and have done no diag. but off the top of my head....assuming seconds/minutes before shut down sudden engine noise then it shuts down. id think mechanical sight unseen.
shot in the dark. maybe another way to look or just something else to rule out

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
poorsoul wrote:

Timing is shot. OBD I won't generate any codes at all if the chain or belt came off.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.