1992 Buick LeSabre 3.8l Stalls occasionally at at low speed

Hope I'm not breaking any rules couldn't find a FAQ. If I am sorry.
I just bought a 1992 Buick LeSabre with the 3.8. Most of the time it runs great but at slow speeds sometimes the check engine light comes
on then the car a little while later it will stall. Once stopped it will restart fine and runs like normal no sputtering or anything all is fine till it decides to happen again.
The same car also doesn't like to sometimes start when warm. When started cold it's normal drive it and get it warmed up and it is hit or miss if it will start right. When it doesn't it doesn't seem to even try. I try giving no throttle or to the floor or half throttle and it just seems to finally decides to start when it feels like it. After cranking for a few seconds there is beeping if that helps.
And Ideas what to look at. I would like to try the little things before I take it into a shop.
How well does OBD-I like this car has help with diagnosing?
If more info is needed I will try to give it if I can
Any help would be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well I would start with trying to get any history codes that may point to the problem, which can be varied, erratic crank sensor, known MAF issues, possible ign module, so you see the diagnsosis can be difficult, short of the common method of replacing parts till it's fixed.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How long are the codes held?
Are they over written or is it somerthjing like the last 10 problems?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You didn't state the mileage, that always helps. If it has 100,000 and never had the fuel filter changed you can try that. Other common problems on things with that kind of mileage are fuel pump, fuel pressure, etc. Have the plugs been changed?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It does have alot of miles smig over 200,000 but still has really good power. Well at least when it's running. Doesn't to use no oil or lose water. Fuel filter should be a more of a high speed problem shouldn't?
Doesn't miss before it dies so don't think it's plugs.
I normally have had older cars and these newer ones act different and seeem to be more abrupt to trouble. Would the fuel pump or regulator be intermediate and only at slow speed or idling?
Thank you to you both for the replies.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
X-No-Archive: Yes
Took it in to the dealer to have them diagnose it. They say fuel pressure regulator and possible the crank sensor. Total about $400 maybe a little more. Sound right for the symptoms
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.