1992 buick regal 3100 lifter noise

I have a 92 regal with the 3100 engine, 120,000 miles, regular oil changes, clean yellow oil . Recently, upon starting the car , it had excessive lifter noise..sounds like all of then are noisy......sounded
like a diesel,as if the lifters were not getting any oil.(it also now runs lousy)The oil pressure checks at 60 psi at the sender switch near the filter.........A local shop confirmed my suspicion and said an oil passage to the lifters must be clogged. Has anyone ever heard of this and is there any easy fix besides taking the top off the motor etc.? How do you even clear out the passage? Can a pressure reading be taken off the top of the engine? Thanks very much in advance tom
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If the engine is sludgy internally, passages could be blocked, failed or spun cam bearings can also cause this. The engine must come apart to determine what's what here.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Under the valve covers it is spotless......Could there still be sludge elsewhere ? How about some engine cleaner / flush? Is there any place to take an oil presssure reading on the lifter side of the engine? I am looking for a miracle .
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.