1994 gmc suburban 1500

my truck has had a tune up and all, but for some reason when im turning it pulls (accelerates)as it should, but when im driving straight it strains and putt's, what could this be.
and also my bucket that holds the extra radiator fluid stays empty, checked, didnt see a whole, but the radiator stays full as it should, could it have something to do with the way my car is acting?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Which engine? Did it do this before the tuneup? What do you mean by "a tune up and all"? What is the "and all" part?

Most likely a leaky intake gasket - especially if it's a 350. Very well known problem.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Another thought that is a common find on the 350 - check the heater hose coupler that goes into the right side rear of the intake manifold. This is a quick disconnect coupler and fails over time. You can purchase a complete female connector in the aftermarket for $10-$20. Installation is obvious and simple. It is highly recommended that if you do replace the intake gasket, you replace this connector as well.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The "and all" is a well-worn cliche sometimes used in conversation. Roy

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.