1994 LeSabre. Heater/AC control not working.

1994 LeSabre. Both radio and heater/AC controls not working. Fan works, heat works, blows from all vents at once. Small indicator on function buttons does not light except when lights are on, all of them are lit.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Complete sentences would make your thoughts easier to understand. We're not charged by the word for internet usage.
It sounds like you are saying that the car will only produce heat, regardless of where the temperature setting is (cool, or hot). Likewise, it sounds like you're saying that the deflectors are not working and the air is blowing out of all of the vents - which is quite difficult to imagine. Are you sure the dash vents and the foot vents and the windshield vents are all blowing with the same force at the same time?
Have you checked the fuses?
I once had a problem on a '92 Park Ave which might have been similar. I really can't quite remember all of the symptoms now but the indicator light problem was like you are describing. In my case it was a low charge in my A/C unit. I topped off the R134A and everything was fine. Just don't over charge your A/C. Is your A/C compressor engaging? It should engage for the defrosters and for A/C.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mvestr1 wrote:

If it has climate control, then the module is bad. If no cc, the probable vac leak or bad valve head.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.