1994 Olds Achieva Problem

I have a 94 Olds Achieva, with 194,000 miles on it. It has been running great with no problems.
The other day, I was just leaving a store, when someone cut out in
front of me in the parking lot. I had to brake really hard to prevent hitting them. When I did, the car stalled. It immediately restarted, but stalled again in a few seconds.
I was able to restart the car a few more times, but it would stall if I took my foot off the throttle. After a few starts/stalls, it would no longer start.
I towed the car home, and the pattern has been consistent. If the engine is cold, it will start and run, as long as I keep the RPMS above 1000-1200. Once I take my foot off the throttle, it dies. Once it is warmed up, it won't restart.
I did try changing the fuel and air filters, in cases they were clogged. I am unsure what to try next, as the problem came on so suddenly, not a gradual onset issue.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Look around for a vacuum line popped off, or the pcv hose disconnected, for starters

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hope it's not this, but one possibility is 'trash' may have suddenly shifted to underneath the pickup tube/sock in the tank. s
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Nathan wrote:

If your car has a maf sensor in the air intake tube, check the tube for cracks between the maf and the tb.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.