1995 Lumina No Park Lights and Dash Lights

I have a problem on my 95 Lumina regarding the park lights and dash lights. At night, when starting the vehicle, I have no park lights, no tail lights and no dash lights. I've checked my fuses... everything is
OK. I've also checked the wiring... seems fine. Only lights that are working are when you open the doors and the headlights (highbeams too). When starting the vehicle with my remote starter, the tail lights and dash lights are turning on, then as soon as I apply the brakes to shift from park to drive, boom, it goes black again.
Help anybody Thanks
Sebastien
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

many elec. problems with their installs--removed them (sometimes/most times) & all worked fine. YMMV. s

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the back of the under hood fuse panel the one behind the battery, I have fixed a few Luminas that the connection had corroded. its an easy check just take the 2 nuts off and the screw and flip it over it should be real noticable. just look for the fuse for the lights.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.