1996 cavalier z24 blower motor

I have a 1996 cav z24 with 150k miles on it. The blower motor does not workk on the low settings but works on the most high one. I don't know what the problem could be. Any help would be greatly appreciated.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
More than likely the blower resistor is blown.
I'm not sure of the location on your car, It may be on the firewall near the blower motor.
If it is there are 2-3 screws holding it in. Remove the srews and pull it out. You'll see about 3-4 coils of wire, if you see one or more of the wires broken, there's your problem.
good luck
========Harryface ======== 1991 Pontiac Bonneville LE 3800 V6 ( C ), Black/Slate Grey _~_~_~297,626 miles_~_~_
~_~_~_~_U.S.A._~_~_~_~_~_
~~~The Former Fleet ~~~ 89 Cavalier Z 24 convertible 78 Holiday 88 coupe 68 LeSabre convertible 73 Impala sedan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The blower resistor is on the blower motor at the floor on the passenger side. It is a little difficult to get to. The one in my 96 and my sons 97 Cavalier corroded as there was no protective coating on the land patterns. The new one was epoxy coated.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.