1996 GMC Sierra Z71 K1500 5.7 ltr 144k miles

I am having problems starting the truck. Right now if the vehicle sits for a couple of hours it will not start unless I spray some starter fluid in the TB. THere are no diag codes. Have checked /
replaced the MAF, MAP PVC. But once the vehicle is started it runs like a champ. If it does not sit long it starts right up. Thought maybe it was a tank of bad gas have run fuel injector cleaner thru the tank. Have not replaced the fuel filter yet. Any suggestions........
Thanks in Advance
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check the fuel pressure. Sounds like a leak down while it sits.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If it is leak down, it should start right up if you turn the key on, wait about 10 seconds. Turn it off a few seconds, and back on for 10 seconds and then crank it.
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hey Al, Thanks for the tip. Tried that, but still did not work . I do not have a fuel pressure test kit. Trying to save a little mula by fixing myself but might not have the tools or the knowledge to give it a go. might have to break down and take it to the shop.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.