1997 Chevy Lumina (NOT-APV) automatic, rough shifting from first to second

My 1997 Lumina (3.1L Vin M, Automatic) has recently begun to shift rough while changing from 1st to 2nd. You'll start off of a stop sign/ light and hit the first shift point where it'll stick for an extra
moment in between gears and then engage very roughly. Every gear shift after that will be smooth as smooth can be.
It's also had issues with it not wanting to go into gear (be it oD, D, 2, or 1) in certain situations (stopped facing downhill, random times when on level surface). You can let it sit idle (in N) for a second (holding up traffic) then try and reshift it (from N to D) and it'll start working fine (and then hit the above problem with shifting 1st to 2nd).
I checked the transmission fluid level (as per the owner manual's directions, which had to park the car level, shift through all gears with brake down, let idle for 3-5 minutes, then take reading). The fluid was at the proper reading (end of the hatched area) and appeared a "salmon" (reddish-pink) color.
------------------------------------------------------------------------------------------------------------------------------------------------- As an unrelated note: Does anyone know how to take the pulley off of the A/C compressor on the 97 Lumina? I started hearing a loud squeal from my belt drive system, took off the belt and hand spun all the pulleys, the compressor one just grinds like mad. I bought a new bearing for it @ O'Reilly's and have no idea which special tools to rent/buy to get that thing off.
--Ryan Metcalf

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.