2.8 gmc jimmy 4wd having issues...throttle body to blame?

Ok, so my little '86 s-15 jimmy is having some serious issues. And I can't get it all fixed at once. So I need to prioritize and fix problems in order. But I dont know what all the problems are. First, when I slow
down to a stop, there is a big shifting sliding knocking sound. I have a feeling its a U-joint. How do I check that? Two, now when I start the truck, it really struggles to get going and dies some times. It is acting like it is not getting any fuel, but then stops. This problem is inconsistent at best. Are there any 'rebuild' kits for the throttle body on a 2.8l v6 for a 4wd jimmy out there? And which are the good ones? Any info would rock. Thanks in advance
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
First you need to check the fuel pressure. They have a fitting that goes inline in place of your filter to do this. Then you need to verify that all the sensors are operating correctly. Is the Check Engine light on all the time? If it is then you do have at least one sensor out of spec and the computer could be in limp home mode.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yeah, the engine light is on. how do i find out which sensor is out of whack?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.