2000 cavalier help/advice needed thanx

Does anyone have or have known, of someone with these problems ?.. I have a 2000 cavalier. Runs fine, but now BUT while I was idling in the driveway..
the fan tried to come on and it almost made the car stall.. I thought it was the alternator being weak.. but it is fine. When it did this really hard draw of power it made the check engine light come on p0113 well this is the intake manifold sensor too high voltage bla bla... if I erase the code it goes away for a while.. NOW the cooling fan stays on when 1/4 temp and won't shut off.. I can go inside come back out 1 hour later and the damn fan comes on. If I erase the OBD II computer codes it works as it is supoose to.. HELP !!! I replacd the temp sensor and ground wire as I thought it was a bad connection in the wire causing the draw,,,could it be my computer ?... but am wondering if there is another sensor ? thanx.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
found one problem LOL looked at the fan relay, it was in backwards.. yes I could turn it around and it worked as well either way the fan shut off after I did this so I assume this repaired the problem....temp stayed @ 90 or half and wouldn't go up and down.. fan stayed on at idle @ 90 so I also gues it won't shut off till the temp drops below the 90

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.