2000 PONTIAC MONTANA

ALL LIGHTS ARE FLICKERING, WHATS THE PROBLEM, BATTERY GOOD, ALT, GOOD, FUSES, RELAYS STUFF LIKE THAT ALL GOOD...........ALSO NUMBER 2 ENGINE COOLING FAN WITH WARM ENGINE,AC ON STILL NOT WORKING , FAN IS GOOD
JUMPED WITH BATTERY IT WORKS, ANY ANSWERS OUT THERE? THANS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If it was all good, the lights would not flicker. Could be a bad ground.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check all connections on the battery and alternator. Take them off and clean them up. Also, like Edwin said, check for a bad ground. And, no offence, but try typing without all CAPS, as it makes it more difficult to read.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I see the problem - your caps lock key is stuck.
You really need to start from the beginning and explain things in English. These abbreviated sentences leave too much unstated. For example... above you state that number 2 engine cooling fan *still* not working - what do you mean by *still* not working? This implies that you've had some problems that you are simply expecting people here to divine. There's a lot of talent in this group, but damn - we're not that good.
As a starting point to get thoughts going and to get you going in a right direction, it sounds to me like you have a missing ground problem. I'd start by looking for corroded grounds.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.