2001 Yukon XL AC stops working after 15 minutes

I have a 2001 Yukon XL with 80k miles. The AC comes on from a cold start for about 15-20 minuntes and then the compressor turns off - just when it finally gets good and cold. Once the compressor turns off - I
can not get the AC to come back on. Once the AC came on when I turned off the AC button (light off) - but it als only worked for a few minutes. It seems that the AC will only work for a limited time and then shut's it self off - and will not work again untill the next days cold start. I have the 8.1L V8 Auto - CA truck. I had my AC go out last year - it would not turn on at all, the dealer replaced the AC clutch - which seemed to fix the problem. Now this year - another AC problem. It all seems to work fine for about 20 minutes - then blows hot. Any help is appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
@#@
Hi Steve these new blend air electronic climate control systems are very complicated they are full of sensors and stepper motors, if only one component is out of whack it causes failure. It sounds like the evaporator may be freezing up , or the outlet air temp sensor may be faulty. An scan of system should reveal codes which will point you in the right direction.
Ray

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.