3.1L V6 Oil Leak

I have a 1990 Chevrolet Celebrity with a 3.1 liter V6. It leaks oil from the rear main seal, as I've found a lot of the 60 degree V6's do. I have literally replaced every seal and gasket in the engine,
including the front/rear main seals, oil pan gasket, head gaskets, valve cover gaskets, and timing chain cover gasket. After removing the engine and replacing the front/rear main seals with teflon seals, it STILL appears to leak oil from the rear main. Quite a bit of it, too. The same as before. It actually doesn't leak very much while it is running, a drop every few seconds, but when it's hot and I shut it off it will leak a good 2-3 ounces or so. I am completely stumped as to why it's still leaking oil. Some asshat over at AutoZone told me to put RTV around the seal. Never heard of such a thing. The only thing that's supposed to be on the seal is oil, which I did before installation. Anyone have any ideas or similar problems?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
(JoltFire) wrote:

I agree! I thought I had a rear main leak for years..... until I found out about this plug and it's o-ring problem. In all honesty, a new o-ring will likely leak again soon. I used permatex silicone and sealed 'er right up. (I removed the plug and put it on the mating surface before putting it back in).
I bet she doesn't leak again ever.
Until the intake manifold starts leaking. :o
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The new style brown o-rings are much more resistant to cracking than the original black ones were.
If one wanted a second line of defense, they could add the paper gasket which used to be used on the V-8 engines way back when.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well I'll be damned. You guys are absolutely right about that oil leak! I can't believe how much difference that made. Not a drop shows up now! Thanks a LOT I owe you guys big time. The seal I bought was a black o-ring from AutoZone for $1.50. I can't quite figure out where it was supposed to go, so I just put it all the way at the top of the shaft between the block and the block off plate and clamped the thing down on top of the o-ring until I figure out exactly where the the thing is supposed to go. Works great for now though. I have a Chilton's manual that has a cutaway diagram of a distributor assembly and it lists the o-ring in there, but is kind of vague on exactly where it should sit. I can't post a picture on here, so use the following address to look at a diagram I drew up:
http://www.joltfire.net/distributor.gif
The block off plate arrow is where the shaft ends on my car since there is no actual distributor. The orange number 1 is where I have the o-ring right now, and it is also the point that meets the engine block since it is the widest point on the shaft. The other numbers are other possible locations (or at least it looks that way in the picture) that the o-ring could be put. Any suggestions on this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In article
snipped-for-privacy@JoltFire.net (JoltFire) wrote:

The black o-ring will fail again, especially so since you've installed it in the wrong place. Where you put the o-ring would be an okay place for the paper gasket listed for the older V-8 engines though, if you wanted to double your protection.
Just below (with-in an inch or so) of where you put the o-ring there is a groove cut into the housing, this is where the o-ring goes. Tours is probably disguised by baked on crud, and it will be rock solid hard, but it's there.
Screw the Chiltons manual, pull the housing out and use your eyes, it should be fairly obvious what an old o-ring and its groove look like. You want the Tan colored o-ring, either from GM or from NAPA, they're in the "Help" brand (Motormite) listings.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If you can get ahold of the catalog, it makes quite an interesting read. Lots of stuff in their product line.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"JoltFire" wrote

Take Neil's advice and get the tan colored o-ring.
It looks like this:
http://www3.telus.net/public/ianrmac/Images/DSC00056-1.JPG
Here is a picture of both a distributor and just an oil pump drive unit. You can see where the o-ring is supposed to be located.
http://www3.telus.net/public/ianrmac/Images/chev%20/DSC00823-1.JPG
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Hot damn, I knew you had pictures on your site, way to go!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
THAT'S where the o-ring is supposed to go?! I figured that's where it should go, but there was a block ring in the way. Looked like metal of some sort and I even tried to pry it out a bit with a screwdriver. I guess I'll take it back out and dig the hell out of it. Thanks a lot for all your help. You guys are the greatest!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If that doesn't yield satisfactory results, use good ol' RTV silicone.
Put it under the "cap" at the top of the shaft assembly and seal it to the surface that it sits on. You'll never have to worry about it again.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I see. I didn't realize that area was at full pressure.
I wonder how long mine'll last. :o
So far so good, though.

the
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.