3300 V6 Misfire/stalling

I have a 92 oldsmoble achieva with a 3300 V6 engine. Recentlly, the car started to stall when cold first starting up. Now its has a hard time starting up. Sometimes it will miss in 3rd gear, but most of the
time it likes to stall from a stop or low speeds, you can just gun it and it wont go. Also if you rev it hard sometimes it will miss, the engine revs will go up really fast then slow down in a loop. I am having a hard time figureing out whats wrong with it because all these problems are very random. There are no codes on the engine and I replaced the fuel filter recently and spark plugs and wires and o2 sensor are only 30,000 miles old. The engine has 164,000 miles on it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
First thing to do is check the fuel pressure especially during the event, should be a minimum of 40 psi, but check the specs.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
smoothstyle01 wrote:

That is a very good engine. Sounds like it needs routine maintenance. Clean the throttle body, IAC, & MAT. Replace any loose or brittle vac. hoses. And as Dave S. said, check the fuel rail pressure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@hotmail.com (smoothstyle01) wrote in message

I bought new coil packs. Works fine now.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.