89 Buick Century, stalling and idle problem

Hi all,
I have an 89 Buick Century (2.8 V6, auto), which has recently started stalling.
When idling, the rev speed drops to almost stalled, then picks up again,
then drops etc. Sometimes it drops so low that the engine stalls. The voltage indicator on the dash shows the voltage swinging in time with the rev count increasing/decreasing. This happens both in gear and neutral (although the effect is a little milder in neutral). It seems to happen less if the air conditioning is on.
The engine has also stalled a couple of times when I have been braking, or just cruising along without my foot on the gas pedal.
Sometimes when I try to accelerate hard (both from stopped and while moving), I put the foot down and it takes 2-3 seconds before I feel any response from the engine.
I have had an intermittent service engine light for some time before this problem, but my mechanic cannot make head or tail of the code (I don't remember the code number, but it wasn't in his book. Another source suggested 'Fire in Engine Bypass' or something).
Any clues would be appreciated :)
Cheers,
Ben
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 1/23/06 10:27 AM, in article snipped-for-privacy@bens-house.org.uk, "Ben Holness"

PCV valve?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.