89 Chevy G-20 Van ECM?

The problem I'm having with checking the computer codes.The engine light comes on when i'm driving,sometimes it comes on at short driving trips and sometimes comes on when I drive on long trips.It shows a code 12 ok
normal....then it shows a 32 code....here's where the problem starts....it blinks a 1 real fast then a 2....the 1 disappears...then it blinks a 2 and another 2....but just before the 2 blinks you can just barely see a real dim blink only in the dark.After a short time it stops blinking and there is no blink at all.Has any one here can tell me what the problem is.Could the ecm be failing?Thanks in advance for any help. Bobby
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 4/22/2011 7:17 PM, bobby swift wrote:

I know what engine and transmission in this vehicle is a state secret, but without that information no one is able to tell you much of anything. Is this a 6.5 NA diesel? A 6.2 diesel? A gasser? Automatic or not? Which automatic? Facts and details are where the answer is, not anything else...
--
I'm never going to grow up.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've been so busy I haven't had time to get back on here,sorry about that.The van has a 350ci...5.7.I put a new egr valve on it...if I'm driving around town,just short trips....then the engine light hardly ever comes on....it comes on at crusing speeds only when I'm slowing down after deaccleration....same 32 code..kinda stumped on this one.Could it be the map sensor?The engine doesn't miss...but it does seem to run a little bit rich...the tailpipe has a black soot in it and it does have a strong oder to it.The throttle body has been completely rebuilt.even shaft bushings.Thanks for any help on this problem! Bobby
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry I forgot to add it's got a automatic trans.700r4.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.