90 CALAIS

No Heat, when the heat is turned on, the A/C constantly blows ice cold. Changed the thermostat and no difference. Any ideas of where to look next?? Also, sometimes when traveling over 40 mph the car will bog down
and slows down and wont go over 25 mph. When this happens there is a strong nasty exhaust smell but after the car is turned off even for just a second, it runs fine. Im thinking either some kind of sensor, or possibly something in the fuel system??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Possible clogged cat, low fuel pressure.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
no heat inthe car is usually due to somebody turn off the hot water supply into the cabinet. i'm guessing the engine temperature is high when you expect to have some hot air in the car.
clogged fuel filter is a possiblity. If the catalic converter clouged you cannot open it by sitting there. to test catalic converter, put it in neutor and floor the gass. if the engine revs at high rpms then the catalic converter is ok. if not, ie does not go above lets say 3000 rpm then you have a catalitic converter problem.
I donot know why you have the smell. It is possible that you dump to much gass into the cylinders also. It might be a faulty injector problem also. It might be the reason why the car loses power above 40 mph.
good luck.
Shep wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.