90 lumina no reverse

90 lumina euro 3.1 auto trannie w/OD. 131000kms (81000mi).
Recently bought this car, did the government safety (in manitoba canada). Drove around for the day. Always a little sticky going into reverse, like
I'd I have to hunt for it on the shift selector. Never a big deal though.
Suddenly in the walmart parking lot, couldn't get it into reverse. Its like its engaged, engine won't go over 2000RPMs, but it won't move.
If I put in drive from Reverse, it sometimes won't move in drive either.
But once in drive, it is perfectly normal, and shifts exactly the way its supposed to. I drove at 120km/h on the way home with no problems whatsoever. Got home, tried reverse again, and no go.
Any ideas? Lots of suggestions to check for loose harnesses and plugs underneath. (I did reverse through a rather large snow drift in reverse that morning, maybe something came loose?)
Anything I should be looking into more seriously?
Thanks! Terry in Winnipeg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
PS and I did check the trannie fluid level while in park, it was perfectly fine, right in the middle of the dipstick hash marks.
I figure that since I get good forward motion that the fluid is not an issue.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It is coming out!

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
out of whaT?
Shep wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/gmc/200612/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
loose brake caliper. Check brake parts. loewent via CarKB.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what the hell does a loose brake caliper have to do with going into reverse?
snipped-for-privacy@gmail.com wrote:

--
Message posted via http://www.carkb.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.