91 chevy astro brake problem

i have a spongy brake problem,i put new brakes on the front,no difference,i havent checked the back yet,ive bled evry bleeder on the wheels twice,i also
have an anti lock brake light lit on the dash,if you pump them twice you get alittle bit of a pedal.anything i,m missing?thanx for the help everyone.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Adjust the rear brakes and check again.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"chillywilly32" wrote

Try what Steve mentioned first, (make sure rears are adjusted properly), but you really will need to find out what is going on with the ABS light. If you have 4WAL (big ugly unit sitting on the firewall right below the master cylinder), you may need a new ABS unit, and it's possible you have some air in there. These units definitely need a scan tool to properly bleed the system if you happened to get any air in the ABS unit. Hopefully, your problem is simple.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You might have 1. Leak 2. Brake line expanding 3. Air in brakes 4. Leaky cylinder on drums 5. Broken spring 6. Master cylinder might be going bad

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.