91 S10 Blazer

I'm trying to figure out this truck it's a 4.3 S10 with 115000 miles. The truck starts fine but if you drive it 10 miles or so it will die and not restart until it has totally cooled down. It doesn't
set the check engine light and there are no codes stored. I was thinking maybe it just needs a good tune up,plugs,wires, rotor,cap and filters but the owner says that it was just done about 10000 miles before this happened. Thanks for any help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Before jumping into the tune up, see if you have spark when it happens and check for fuel spray from the injectors, I assume this is a TBI engine. A lack of either would be a different direction than a standard tune up.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

mixture getting to the engine? You said 10 mile of travel before failure. Would 20 minutes of idling do the same thing? To me this sounds heat-related; as if the engine is just getting to normal operating temperature before something malfunctions.
Can you provide more info? When you attempt to restart the truck, what does the engine do? Any fuel pump whine at key-on? When it dies, what does it do? Be specific about the behavior.
Lots of things could be the cause here, i.e. ECM, ignition module, fuel pump, crank sensor, and much, much more.....
Not Dead Yet
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.