93 Buick Lesabre Brake light problems

While driving my 1993 buick lesabre limited one day, I smelled a strong electrical burning smell. Later that evening I noticed that my instrument panel back lights went out and my brake lights don't work
either. When my lights are turned on only my headlights work and nothing else. I have read that sometimes the turn signal lever could produce this problem but my turn signals work ok, in fact they are the only lights that work in the rear. Any help on this issue?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If you burned up some wiring, you should still be able to smell it and you'll need to use your nose a bit to try to find it. It's kind of straight forward - you smelled burning and you lights quit working... now you have to find the damaged wires, and from there figure out what caused the over current condition. It could be something as simple as mice having eaten through insulation which created a path to ground, or it could be something in the circuit has failed. No way to tell without getting your head in there. Have you recently done anything like add a stereo, or in any other way messed with the wiring?
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.