94 Buick LeSabre stalls

My 94 Buick LeSabre has been hesitating, for the last several days. Today, it stalled several times. It would start again, go for a few blocks, then the engine stoped. Near home, it would stall after going for about 100 feet
or so only.In my driveway, it wouldn't start. Then, after about 5 minutes it started but went for about 20 feet before it and died.
After it was stoped for about 15 minutes it started and I drobe it back and forth in the driveway. Then it stalled.
It seems to me it is worst when hot. Any sugestions on what it could be?
Thank you.
Tony
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Alpha One wrote:

Among other suggestions, check out the crank sensor.
---Bob Gross---
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I replaced the Crank Sensor and the problem continues. Tomorrow I am going to test other sensors. It seems this buick does not have a MAP sensor.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Seems"???? Did it fall off? Look at the "Emission System Hose Routing" sticker under the hood. Do you know what a MAP sensor looks like? It's black, made of plastic, has one electrical plug and one vacuum line, both of which plug into the bottom. It's not part of the intake. From the top it looks quite inconspicuous. It's the size of a crushed cigarette pack.
-- GW - Conservational Ergonomist - note incorrect email address "It's good to yell at people and tell them you're from Tennessee. That way you'll be safe." - Gary Busey
Alpha One wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Wow that's wild. That 3800 engine should be the same in a LeSabre, Park Ave, Bonneville, Eighty-Eight, or Ninety-Eight. Maybe someone with one of those can help. I don't have the book on that, but I can't believe there's no MAP. Sorry I can't help more, GW
Alpha One wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.