94 LeSabre will not start

My 94 LeSabre will not even turn over. I hear a relay under the hood click, but not the solenoid on the starter. All fuses are Ok. For the last couple
of months, maybe once every 1, 2 or 3 days, the car would stall but it would start again immediatly. Sometimes it would hexitate but pressing the gas would keep it from stalling. It was like if the ignition was turned off. No error codes present. Today, it just went complely dead except for the clicking realay. Batery is new and charged. minutes before it was starting and running fine. Can it be the scurity system? I have a scan tool and when I connect it to the computer plug it says "Operating error... Check connection". Could it mean that there is no power applied to the ECM?
Than you
Antonio
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check ground. A faulty ground can work one minute, not the next, especially if wires get moved or tugged.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Start with looking for a bad ground, then see if the solenoid on the starter is getting 12v, with someone holding the key in the crank position, also does this car have a key/vats security system?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes. When it stalled days ago and the other times I asked myself if it could be the security system, because I have checked most everything else like fuel pressure, crankshaft sensor, spark plugs, etc., and couldn't find anything wrong, but I guess it can be anything.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You have a flaky ECM buddy.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Are you getting a Security or Theft System light on after a failed start attempt?
The theft deterrent system won't cause the engine to stall while driving, however, so I don't think that's the problem.
--
Robert Hancock Saskatoon, SK, Canada
To email, remove "nospam" from snipped-for-privacy@nospamshaw.ca
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.