94' Saturn cranks but won't start

I've got a '94 Saturn SL2 which will not start, just cranks. It was running fine until I parked it and tried to start it 2 hours later. Good battery, cranks fine, just will not kick over. I suspect the
timing chain at 83K but was wondering if there is anyway to determine if it is bad without removing the cover. Yes, it does have a half tank of gas.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
says...

Goto rec.autos.makers.saturn
or look at the archives

http://groups.google.com/group/rec.autos.makers.saturn/search?q=%22no+start&start=0&scoring=d & No it is not the chain. You should check to see if you are getting fuel and spark.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks you.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Why do you suspect the timing chain? That would be way, way down on my list of suspect items. Probably not even on my list. I'd be looking for fuel delivery and spark first. Gas in the tank is a good thing but gas injected into the cylinders is a totally different matter and that's one of the things I'd be looking for.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.