96 Cavalier (Engine Light at 100 km/h)

Hi gang,
First post. Very informative group.
As the subject says, I have a 96 Cavalier Z24. When I'm travelling on a highway where I can go 100 km/hour or more, after a few minutes
travelling at this speed, the check engine light and the ETS light come on. At the same time when they come on I can feel a reduction in engine power for a split second, then the car seems fine. After an hour or so of city driving, the lights go off and stay off until I'm on the higway again. I was told it wasn't anything major to worry about.
Any thoughts on what this may be?
Thanks for any help or information.
Sherman
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Something in the ABS/ETS system is failing. You need to have the codes read out of the computer to determine what is causing it. Some parts stores (AutoZone will read them for you for free. It is possible one of the wheel sensors is failing at high speed nut that is only speculation. Computer readout is the only way....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You need to get the trouble code read out to have any real idea what is going on here.
The reason the ETS or TRAC OFF light comes on is because it gets disabled (on this car, anyway) when any trouble code is set in the PCM.
--
Robert Hancock Saskatoon, SK, Canada
To email, remove "nospam" from snipped-for-privacy@nospamshaw.ca
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.