97 GA 130k mile stutters a bit when fuel gets near empty

Recently I have noticed that I can't run my fuel all the way to E like I used to. Now as it gets close to E it seems to get lean a miss a little bit.
Runs fine though wants I fill it up again. Is my Fuel pump going bad? Had fuel filter replaced once at maybe 60 or 70 k miles.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You're damaging your fuel pump every time you suck air with it which happens before you even get to 1/8th of a tank. It's time to fill up when you dip just under a quarter tank. From what I've seen gas is still cheaper than fuel pumps. And yes I'm sure you're due for a filter, see owners manual.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Agreed. Don't ever let your gas tank go below a quarter whenever possible - it is hard on the fuel pump.
says...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
says...

Thanks, I will replace the pump and filter as soon as I get a chance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try the FF first.Then get ready for a pump.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.