97 GMC Jimmy no start

I just purchased a 1997 GMC Kimmy and ir ran great for 3 days, on the fourth day i started it and it ran for 5 or 6 seconds and just shut down, hasnt ran again, i changed the timing chain, crank sensor, fuel filter and
still no start, anyone have any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you have spark, do you have injector pulse and fuel pressure, why the timing chain? related, unrelated? What engine, how many miles?

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yeah, stop throwing parts at the damn thing and do some detective work. First off check for spark and fuel. Use a spark gap on a plug wire to see if there is spark. Use the fuel pump run wire under the hood to power up the pump, is it working? (you should be able to hear the pump whine) Check for fuel pressure. Since it is a 97 plug a scanner into it and see what shows up.
--
Steve W.

"icorrectu378" < snipped-for-privacy@aol.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
there is spark and fuel just wont fire over. has 4.3 vortec with 140000 miles, so i was told it would be either timing jumped a tooth or crank sensor so i changed both, still does not run.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
timing cannot jump since it has chain. Check distributor,
pull one of the spark plugs, and check it out if itis wet with gas., If not put it or crank it without spark plugs to get same gass smell..(donot over crank..)
Check your oil if it is too thin.(it might point out a faulty injector)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
if you changed timing chain, i putmy money on wrong timing. Eighter your distributor is 180 degrees wrong, or you missed a toot. Sorry for my previous message(i was just ignorant not to read your message right)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.