97 GMC Savana Won't Start - HELP

I would really appreciate any ideas, here my situation:
1997 GMC Savana with the fuel injected 5.0L V8 Car was running and stall and will not restart.
it has fuel going to the fuel pressure connection it has spark the engine turnovers
no life, not even a sputter
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Will it start if you spray carb cleaner into the intake, check fuel pressure also, is this a Vortec or TB fuel injection?

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It did start with starting fluid. It has MFI MULTI-PORT FUEL INJECTION, I'm not sure if that is Vortec of TB. I checked the valve at the fule pressure connection and gas flowed out, should there be more pressure than that or do I need a tool to measure the pressure? -Thanks,Y_COYOTE
Shep wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/gmc/200607/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You need 60 psi to operate the injectors only a fp gage wiil give you accurate diagnostic info.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I will find a fp gage and see what pressure I have - Thanks for the help
Shep wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/gmc/200607/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Y_COYOTE wrote:

I had a similar problem about a year ago on a Chrysler K car, and the kind folks here reminded of the 3 basic things required to have an engine start:
1 - Adequate fuel delivery 2 - Spark 3 - Proper timing
In my case, while I had spark and fuel delivery, my timing belt had been chewed up by a damaged timing belt tensioner pulley. Took me a while to tear the top half of the engine apart to verify, but once we found it and repaired it, that car was good to go again.
Please be sure you check all of these things, ok?
Best wishes!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's starting to look like a fuel delivery problem. Thanks.
Viper2 wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/gmc/200607/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.