97 Malibu - no electrical power

IHA 1997 Malibu. there is no power to the car at all. The dome lights do not even come on when the door opened. It is as if there is not even a battery installed. I put in a new battery but wiht the same
results. The previous day it was running fine. The next morning, when the key was turned, I heard the click of the circuit in the egnition engage, but nothing else. When tunred again, not even the click happened.
Ideas?
Thanks!
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check for bad battery connections at both ends also all the main grounds.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
scotward wrote:

Bad battery.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"" wrote: > scotward wrote: > > > > IHA 1997 Malibu. there is no power to the car at all. The > dome lights > > do not even come on when the door opened. It is as if there > is not > > even a battery installed. I put in a new battery but wiht > the same > > results. The previous day it was running fine. The next > morning, when > > the key was turned, I heard the click of the circuit in the > egnition > > engage, but nothing else. When tunred again, not even the > click > > happened. > > Bad battery.
Thanks for the reply. Bad battery? Close. Upon further inspection I noticed the threads on the positive battery cable were corroded. Once cleaned up, everything worked perfectly. Figures, I immediately go for brain surgery when it only needed a bandage.
Thanks again for the reply. Had you not suggested the battery I would have not inspected the connections more closely.
Scot
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.