'97 Pontiac Grand Prix ticking?

Got a 97 Grand Prix with the 3.1L V6. Has 123,000 miles. It is making a ticking sound when I first start it up and then goes away in 30 seconds or so. Never makes the noise in park at
an idle or on the road, just when first starting up in the mornings. Got any ideas? Thanks ahead of time.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do a google on 3.1 piston slap...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Most likely suspect is 'piston slap' for which some of these GM engines are notorious. If it's not severe & goes away in 30 seconds, nothing to worry about.
Regards, Al.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Or maybe a valve lifter that is draining down when parked???

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, its another GM design problem. GM says its harmless, but it has something to do with bad tolerances in the design. Mine does it too, its embarrising when you start it up in the morning if parked next to someone in a Toyota or something, You they are saying to themselves "sounds like a piece of shit".

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.