99 Buick Century Cruise-Control kicks off intermittently

My 99 Buick Century's Cruise-Control Kicks off quite frequently for no apparent reason. Not related to bumps in the road etc. Not particularly related to time turned-on. Exercising the lever-switch, or foot brake
does not disclose any clue. My best guess would be to arbitrarily replace the brake-pedal switch since it gets much use. (56,000 mi on car). Can anyone share their experience, or suggestions? Thanks in advance!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Gene wrote:

I had a Buick that started doing that, and I thought it was the servo. I took it to a GM specialist, and he said it was the stalk switch control, so he replaced that and it worked. Then six months later it acted up again in the same way. I took it back to the same guy and he said it was probably the stalk switch control. I told him to look harder. Then he replaced the servo, and that solved the issue once and for all.
---Bob Gross---
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My buddy had the same thing in his 91 Buick and it turned out that it only happened with one of the keys! A security chip in a spare key was going bad.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@csl.uiuc.edu (Gene Gardner) writes:

---------------------------------------------- .....SOLUTION posted later in this news group...i.e. steel wire used to hold tight, the nylon switch assemblies operated by the brake-pedal.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.