99 Yukon engine misfire

1999 GMC Yukon 94000k 350
I am getting a misfire code on #5 cyl, The rep. said to rebuild or replace engine. Was a little reluctant on doing that so I ask for a compression test to
be done. They said that would be $120 so I said OK.. No. 5 was 140lbs
and adjoining cyls was 150. I asked what the dif was between the wet and dry and he didnt know what I was talking about. After several calls he got with the mech. and he said they done wet/dry on #5 with no
diff. also a leak down test showed it was bad rings. With these responses I dont know how good of a job was done on the tests. I replaced the plugs and the light goes off for a while and then on for a
while. My biggest question is how to rule out other possible problems before moving on to the bad rings. Such items as EGR valve, bad ignition, fuel, etc.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you have a noticeable misfire, roughness, or just the code?

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had a noticable misfire prior to replacing all spark plugs, After replacing plugs the light was still on and then later it went off. It is back on again now. I can't detect a roughness now...
Shep wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.