abs codes on 04 lesabre

hi,
the car was hit on the front left side in a minor incident. replaced strut knuckle hub rotor and pads. a few weeks later abs codes started to intermittently being thrown.
the codes are: C1225 - left from wheel speed signal erratic C1232 - left front wheel speed signal opened or shorted C1236 - low voltage failure C1276 - delivered torque circuit fault
i have inspected the wires back to the harness and dont see any thing chafed or any other issue.
suggestions?
tia, peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
peter wrote:

Replace the left front sensor and the wiring. Sounds like the wires got stretched and damaged.
--
Steve W.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Steve W. wrote:

isnt that an intragal part of the hub i replaced? if not, do you have a url with a pix for me to look at?
thanks, peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
peter wrote:

The sensor is attached to the hub. Most new hubs come with the sensor, others do not. Depends on where you got the part. The harness comes from that sensor up to a connector on the sub-frame. Then from that connector up to the ECM. If you have access to a scan tool there are tests you can do to check the harness using a jumper wire. You will find them in the service manual.
--
Steve W.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.