ABS locking on startup

Here's an interesting problem:
I just got a 1994 Buick Roadmaster from a dealership, in great shape, excepting one thing: When I first turn it over, the brakes jam solid until
the car warms up. Here's the blow by blow:
The car is turned over.. fine The car shifts in gear... fine brake applied - you touch it, it hits the brakes HARD. This is not a case of me underestimating sensitive brakes - it fixes itself after two or three extremely hard stops.
Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
change the rear shoes and turn the drums... you can help this from happening again if you use some silicone and seal the backing plates as much as possible... water is getting in and rusting the shoes.Lots of times it runs down the ebrake cable and into the brakes.. first couple brake applies are scraping the rusted metallic shoes clean... this crud rolls off and jambs the brakes on... wouldn't hurt to check out the axle seals, and brake cylinders also.... Bobo

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Good advice!! I appreciate it :)
Matt

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.