Anti-freeze in oil

I have a 97 Chevy Astro van that the water pump went out in it. It got hot when the pump went out. I replaced the pump. Drove it about 20 mi. when it
started to have a lot of white exhaust. I drained the oil. It has antifreeze in the oil. Could the heads warped when it got hot?
Kevin
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"BR" wrote

I'd say that's a reasonable guess.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Anti-freeze in oil Group: alt.autos.gm Date: Fri, Jan 9, 2004, 3:06pm (CST+1) From: snipped-for-privacy@hotmail.com (BR) I have a 97 Chevy Astro van that the water pump went out in it. It got hot when the pump went out. I replaced the pump. Drove it about 20 mi. when it started to have a lot of white exhaust. I drained the oil. It has antifreeze in the oil. Could the heads warped when it got hot? Kevin
May have been warped or may be your intake...You need to do a compression test ...Also to see if its your heads or your rings need to do a leak down test....Tell me this is it still getting hot? If is not running hot more than likely you blew the intake gasket if your heas were warped or you gasket bas bad it would heat up. But to be sure do a compression test on your cylunders if all is goo just replace the intake gaskets.........What size motor does it have in it? Steve C
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes.
__________________ Note: To reply, replace the word 'spam' embedded in return address with 'mail'. N38.6 W121.4
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@spamsack.org says...

Yeah the heads on those engines tend to warp easy. Only takes overheating one of those once to ruin them. You can do a cylinder leak down and a cooling system pressure test to confirm this.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BR wrote:

ruined the cylinders too. Cost is about $3500 for a rebuilt.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.