Astro van tranny woes

Good day: Sorry for the repost under a different title but I really need help. My 2 wheel drive Chevy van has a tranny problem. I believe it to be a
sensor as this only happens when it is warm and I have driven for an extended period (25 kms or more). What happens is after a stop the tranny (auto) all of a sudden shifts really rough out of low slightly rough out of second then is fine. If I pull over, shut the van off, wait a few seconds, all is well and god is good once again. Anyone have any suggestions as what sensor is gone and where I would find it? Thanks all. Leo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wow this happened to a friend of mine.. your gonna need a scan tool and friends at a gm dealer.. the scan tool will tell you which solenoid gave up. they shift with solenoids and .. or the problem is in the computer program. if its the solenoid replace and be happy the computer replace it reprogram it and be happy. his van the solenoid shorted and burned up the computer.. the solenoids heat up and short a scan tool will tell you which one is sticking after a long drive. their not physically hard to change open the tranny case where the filter is and their all right there. it sound like the 1-2 solenoid is shorting but thats just a guess.. good luck.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.