Buick Century 2000 Electrical problems, lights and locks, etc.

In the last 24 hours all of this has happened; 1. I went to lock in the high beams and it would not lock in, this has happened many times before, but this time ALL the lights went out. The only
way to have any lights was to hold the high beams on. After 5 minutes or so, something clicked and the lights came back on.
2. The back window behind the driver will power down, but will not power up. ( I had to wedge it in to keep it up while driving so the wind vibration didn't kill my ears)
3. While driving down the road the driver door will unlock continuously, this is driving me crazy.....
4. Locked the car, went to bed, and the neighbor called to tell me that the lights flashed on and off all night, so does that mean the lock and unlock was playing all night as well?
Can this be a computer code malfunction? I don't want to be ripped off when I go to have it repaired.
THANKS to anyone that can help me with this one.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Maybe a bad ground, like the ones under the front doors.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks, I'll check it out first thing in the morning.
Rachel
80 Knight wrote:

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/gmc/200706/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.