Buick regal that shudders

Hi all,
I own a late modell '94 Regal and I love it, but lately it starts to shudder when I drive between 45 and 70mph. This only occurs when it's in the
highest gear and I slighty press the accelerator or if I use the cruise control to gain speed. Come to think of it, it also happens
Is this a transmission thing or could it be the engine?
Thanks in advance,
Michael
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like bad plug, wire or coil type problem. It also could be a bad torque convertor but I would look at the ignition first.

the
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It could also be unbalanced tires.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's usually a bad plug wire causing a misfire. Time for a tune-up.
-- GW - Conservational Ergonomist - note incorrect email address "It's good to yell at people and tell them you're from Tennessee. That way you'll be safe." - Gary Busey
Michael wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mmmm, after reading some stuff about CV joints it seems to be that problem spot on. I've also experienced a clicking (rasping sound) for some time during parking, coming from the front left-side of the car when it's in the maximum steering position... That also seems to be CV joint releated.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.