chevy lumina 92 "low coolant"

chevy lumina 92 V6 3.1 L - yesterday i got the low coolant light on for a couple a minutes (cold engine) than went off; drove 80 kms (50 mls) then today after 12 hrs turned the engine on and got the light again,
turned off engine and now it would not start at all, checked the level and indeed i'm missing coolant (it is empty); i'm pretty confused: shouldn't say that is low when it's low not when is gone? the gauges for GM cars seem to be pretty primitive, it happened the same with the oil level is it too late? is the gasket gone? should i try to refill coolant? would appreciate an advice, thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check for coolant in the oil first, take the oil filler cap off look for signs of coolant on the cap. Then fill it with water just to test it, pressure test the radiator and look for external leaks, radiator, coolant hoses, water pump. Do not drive it!

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Having just had a plenum failure with a 3800, and realizing that your engine can have water leakage problems of a similar or slightly different nature, I would suggest that you may need to take a close look at the gasket and sealing problems know for some of these engines.
You might have a leak of a different nature, but since you say yours wouldn't start, you may be getting water in the cylinders.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.