Clicking noise - 89 Astro 4.3

1989 Astro 4.3 engine I am getting a clicking, tapping noise on idle. Doesn't get worse if you speed it up, in fact it goes away. Doesn't sound like the low
growling noise of lower end problems - it is more of a metallic click. The noise goes away if you put it in gear. When driving, it will come back when you slow down or let off the gas (like when you come up for a stop sign). Hard to tell where its coming from but seems to be either the passenger side of the engine or towards the front. Anyone know what it might be? Thanks Gary
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just from my personal experience, it sounds extremely similar to when my flex plate started to crack. It went away in gear, and shortly before I got it fixed, it was VERY loud. It was tiny little cracks that are very hard to see when it's still installed. They usually are around the bolt holes. Like I said, from my experience, it sounds exatcly the same.
Oh, side note too. If you didn't know, the starter uses this to crank the engine. I didn't have any starting problems, just one loud clicking noise at idle, that went away when put in gear.
Good luck,
Tony
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.