electrical gremlin...

96' Chevy Cavalier, 125,000 miles, 3-speed auto, 2.2 liter
Intermittent electrical glitch - dash warning lights come on & stay on, temp gauge stops working,, cruise control stops working, radio & lights do odd
things. Sometimes all of this happens together, sometimes just some of them.
Bad connection somewhere? Computer gone nuts?
Thanks in advance..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
P.S. - I did disconnect the battery for a full 24 hours thinking that perhaps the computer just needed to be reset; no change.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Look for a bad ground at the battery or the engine. Possible bad ign. switch also.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just noticed that the trouble seems to begin when you put the thing in gear.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The fact that it does it gear makes me think a ground is at fault, and acts up when the engine moves. I'd start at the neg. cable, add a heavy jumper right to frame rail, and a 10 guage to cowl and radiator support.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think you're onto something. Now that I think about it, I encountered a similar problem on a car I owned years ago. There was a ground strp from the chassis to the engine that had become so rusty that it was no longer functioning properly. I'll investigate tomorrow.
Thanks!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.