electronic dashboard display problem 2000 LaSabre

I bought a used 2000 Buick LeSabre Custom from a dealer with, unfortunately, no guarentees -- sold as is.
Normally within a few seconds after you start the engine, the electronic
dashboard display and the clock display both come on at the same time. But at random times they may come on after a delay of up to one minute, and a couple of times they did not come on at all for the entire trip (makes driving rough, you can't see what gear you are in or the speedometer at night). I can't see any rhime or reason to when it fails.
Anyone else have this problem and know what the cause might be, or how to diagnose. The randomness of the problem will make it tough to know if I have it fixed or not.
TIA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

unfortunately,
But
If it were my vehicle I would call around to wrecking yards for another display. While it may be a PIA to replace I am guessing a power supply problem within the dashboard display itself. Could be a cracked circuit trace or cold solder joint or some such.
But before doing this you should at least pull both the battery and alternator and take them to an auto parts place which has an alternator test bench and a battery load meter, just to eliminate any possibility that you have a power problem in the car itself.
Ted
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Probably the cluster. Should come out fairly easily.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.