Engine Vibration 2000 Lesabre

On a 2000 lesabre 3800 engine seems to vibrate slightly at Ideal, but at about 2000 RPM the vibration seems to cycle smooth to rough about 3 times a minute going down the highway. It causes a minor shudder of the car. It
still has plenty of power and gets good gas milage. Any Ideas what it might be? I have and an extended warranty on the engine & drive train. The car hasd 69K miles on it.
Thanks Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bill wrote:

My first guess would be the fuel pump. Next would be the timing.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When I rev the engine out of gear to 2000 RPM there is no vibration, Also the tires on the front are new. Could it be a balance problem?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You mean tire balance? Tires arent rotating when you are out of gear. Have you had any recent work done to your engine? How long has it been doing this?
says...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bill wrote:

Ah - if it revs nicely when not in gear, it's likely the MAF or whatever siummilar fuel/air sensor your engine has.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
MAS was replaced about 5 months ago new air filter at that time also.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bill wrote:

Then it's most likely the other end of the equation - the sensor(s) or packs are sending the MAF bad or inconsistent info or not firing 100% of the time.
Q: does it run rough when pressed - like it's bogging down, or is it more of a hit the gas and not enough happens(starving for fuel)?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When you press the accelerator down the engine revs very quickly no hesitation whether in gear or in neutral. This seems to happen or be more pronounced at a constan RPM and load. When the MAS was changed the dealer did a fuel injector cleaning procedure and I noticed that the gas mileage dropped 1 or 2 mpg. Is it possible that the O2 sensor may have been damaged & is now failing?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Start off simple. Inspect your plugs and wires. Make sure your wires arent arching and are within spec on their resistance. Make sure there is no unusual build up or discoloration of your plugs. Also make sure they are in the right order. You never said the mileage or I missed it. Make sure your cooling system isnt leaking as well. If all of that turns out ok check your coils then your ignition module and your crank sensor. You can also check the balance of your injectors to see if they are spraying evenly and check the ecm side to see if they are being pulsed. It takes a lot to make a 3800 run rough. The things run damn near as smooth on 2 cylinders as they do on 6.
says...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like ignition wires or coil and module check the wires at the coil pack for rust or corrosion only take 1 wire at a time so you don't cross them with the engine off you don't want to check them with the engine running due to the high power coils will shock you.you can try to power brake slightly to put a load on the vehicle or spray water and listen for spark water will make it more noticeable
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I went back to the tire dealer the front tires were out of balance a 1/2 oz of each side and they replaced one front tire. About 1/3rd of the center rib of that tire was not straight was out (squiggly) about 1/2 inch. So maybe that was it. I still need to test it on the road to see.
Thanks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.