fuel leaking.

i have a 1989 buick regal 2,8 engine, there is fuel JUST comming out of the middle of the throttlebody.just when i turn the key to the on position. there is no fuel on, or near the fuel injectors or the fuel pressure
regulator. IST question... is it possible that either the f/ injectors or the f/ pressure regulator could be leaking with out any fuel being on or near them,BUT THE FUEL IS ONLY SEEN COMMING OUT OF THE MIDDLE OF THE THROTTE BODY( carb opening)? also, i have a port fuel injection sysyem. i didnt want to through you off when i said throttlebody.WHATS INPORTANT IS THAT WHEN I REMOVE THE FUEL LINE , JUST FROM THE UPPER THROTTLEBODY, (WHERE ALL THE VACUUM LINES GO INTO THE UPPER TH/BODY) AND PUT THAT END INTO A JAR AND TURN THE KEY ON ... THEN THE FUEL GOES INTO THE JAR AND NOT OUT OF THE TH/BODY, NOW THE OTHER END OF THAT FUEL LINE GOES INTO THE FUEL PRESSURE REGULATOR. CAN THIS HAVE ANYTHING TO DO WITH THE ECM OR THE PROM?I HAVE ALSO BEEN GETTING CODE 33 (MAP SENSOR TOOK OFF PLENUM & FOUND MAP SENSOR VACUUM LINE TOTALLY CUT OFF AND THE VACUUM LINE THAT WAS SUPPOSED TO BE IN THE MAP SENSOR WAS IN THE CRUISE HVAC AND VISA VERSA, AFTER FIXING EVERYTHING.. I RE SET THE ECM AND STILL THE CODE 33 CAME ON WHEN I USED MY CODE READER, I ALSO CDE 33 COME UP AT A DIAGNOSTIC CHECK AT A SERVICE CENTER, BEFORE I FIXED THE V/LINES. PLEASE HELP! I HAVE BEEN GOING THROUGH THIS FOR A COUPLE OF MONTHS, 1 ST WITH ALL THE V/LINES AT LEAST I WAS ABLE TO DRIVE THE CAR FOR 1 OR 2 MILES THEN THE IDLE WOULD GO UP AND DOWN AND WOULD STALL AT MOST STOP SIGNS, AND ONE MONTH LATER AFTER CHANGING MOST SENSORS...THE CARWOULDNT START ONE DAY AND FOUND OUT THAT I HAD ANOTHER PROBLEM THIS FUEL LEAK, NOW I CANT EVEN START THE CAR TO SEE IF I HAD FIXED THE ORIGINAL PROBLEM, AS I SAID THE CODE STILL READ 33 AFTER FIXING ALL V/ LINES...COULD ALL THIS BE THE ECM? MY ECM IS ONLY 9 MONTHS OLD, BUT KEPT THE ORIGINAL PROM.....SORRY IF THIS IS SO LONG.... PLEASE HELP!...THANKYOU FOR ANY ANSWERS.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.